myOFiber Portal and novin Business are down
Resolved
Sep 4, 2026 at 1:08pm UTC
myOFiber Portal recovered.
Affected services
Updated
Sep 4, 2026 at 1:07pm UTC
myOFiber Portal is degraded.
Affected services
Updated
Sep 4, 2026 at 11:56am UTC
myOFiber Portal recovered.
Affected services
Updated
Sep 4, 2026 at 11:39am UTC
myOFiber Portal is degraded.
Affected services
Updated
Sep 4, 2026 at 11:29am UTC
myOFiber Portal recovered.
Affected services
Updated
Sep 4, 2026 at 11:27am UTC
myOFiber Portal is degraded.
Affected services
Updated
Sep 4, 2026 at 11:20am UTC
myOFiber Portal recovered.
Affected services
Updated
Sep 4, 2026 at 10:57am UTC
novin Business recovered.
Affected services
Updated
Sep 4, 2026 at 10:33am UTC
novin Business is degraded.
Affected services
Created
Sep 4, 2026 at 10:27am UTC
myOFiber Portal is degraded.
Affected services