Back to overview
Degraded

myOFiber Portal is down

Dec 26, 2025 at 7:35pm UTC
Affected services
myOFiber Portal

Resolved
Dec 26, 2025 at 10:07pm UTC

myOFiber Portal recovered.

Created
Dec 26, 2025 at 7:35pm UTC

myOFiber Portal is degraded.