Back to overview
Degraded

myOFiber Portal is down

Mar 29, 2026 at 3:14pm UTC
Affected services
myOFiber Portal

Resolved
Mar 29, 2026 at 4:44pm UTC

myOFiber Portal recovered.

Updated
Mar 29, 2026 at 3:32pm UTC

myOFiber Portal is degraded.

Updated
Mar 29, 2026 at 3:26pm UTC

myOFiber Portal recovered.

Created
Mar 29, 2026 at 3:14pm UTC

myOFiber Portal is degraded.