Back to overview
Resolved
myOFiber Portal and novin Business are down
Jul 15, 2026 at 7:52am UTC
Affected services
myOFiber Portal
novin Business
Resolved
Jul 15, 2026 at 7:59am UTC
novin Business recovered.
Affected services
Updated
Jul 15, 2026 at 7:59am UTC
myOFiber Portal recovered.
Affected services
Updated
Jul 15, 2026 at 7:57am UTC
novin Business is degraded.
Affected services
Created
Jul 15, 2026 at 7:52am UTC
myOFiber Portal is degraded.
Affected services